Wednesday, March 12, 2008

Poppler 0.7.2 (0.8 RC1) released

So one week after the scheduled date, we have released Poppler 0.7.2.

This is the first release candidate of what will be Poppler 0.8

From now on no API nor ABI changes are allowed unless TOTALLY necessary. Only bugfixes until we release and branch 0.8

We will try to follow the planned schedule with a 1 week delay applied, that is:
* March 19 -> Poppler 0.7.3 (0.8 RC 2)
* March 26 -> Poppler 0.8.0

And now onto the changes

Major Changes:
* Improve font matching not forcing default values onto Fontconfig
* Add preliminary annotations support in the glib frontend
* Initial Movie support in the core
* Make GDK dependency optional in glib bindings

Minor Changes:
* Make the core able to read mime types of embedded files
* Qt4 API for accessing mime types of embedded files
* Handle correctly check state of optional content groups
regarding parents state
* Avoid setting singular CTM matrices on the Cairo backend
* Improved Qt4 API to get character position
* Qt4 api documentation improvements
* Qt4 minor stability fixes
* Proper lib64 Qt detection
* Fix build when compiling without cairo support

Testing, patches and bug reports welcome.

5 comments:

Enrique said...
This comment has been removed by the author.
Enrique said...

Hi,
Currently, using Okular 4.0.2 and libpoppler 0.6.4, this document is not properly rendered.

Adobe Reader issues a warning, but seems to show it correctly.

Will Poppler 0.8 fix this issue?
Thanks.

Albert Astals Cid said...

This is not poppler bug tracking system, if you care for that problem please report it there.

Augu said...

Does "Movie support" mean embedded movies in pdfs? For example those included with multimedia package in beamer presentations?

This should be great!

Albert Astals Cid said...

@augu: It means the basis for that are done yes, some work is still needed though