Monday, October 12, 2009

Dear lazyweb: intel graphics problems

Here i am trying to open a svg file with inkscape and i get this.



Any idea what can be the problem? Fedora 11 uptodate with Intel Corporation 82852/855GM Integrated Graphics Device.

10 comments:

derive said...

Is because Fedora 11 use xorg-x11-drv-intel 2.7.0 instead of the 2.8 version.

The 2.8 version fix all this!

maninalift said...

That's not a bug it's a feature: X11_3D_magic-eye mode ;¬)

Achim Bohnet said...

The 2.9 release notes mention many problem with 8* chips are fixed:

...
Major fixes in 2.9.0 compared to 2.8.0
======================================
* Multiple fixes to make the driver stable for 8xx chipsets, (855GM,
865G, etc.). The 2.8 driver series was extremely unstable with many
of these chipsets.
...


see http://lists.freedesktop.org/archives/intel-gfx/2009-September/004401.html

Anonymous said...

That's because you use KDE in Catalan.

Elv13 said...

Inkscape is buggier and slower with every new versions, I don't like that but have to live with some Inkscape specific glitch too. It is not always caused by graphic drivers, I got similar bugs with NVIDIA too.

Stuart said...

Not that this helps you much, but I ran in to something very similar with Hugin (also on Intel, Fedora 11). Though it was on an old laptop I don't use much so I forgot about it and never got around to filing a bug.

deviljelly said...

Hi... did you upgrade to libjpeg.so.7 recently?

Anonymous said...

https://fedoraproject.org/wiki/Bugs/Common#Miscellaneous_problems_with_Intel_graphics_adapters

fyanardi said...

Yes, it is very likely an Intel driver bug. I once encountered it when using Intel 2.7 driver with 945GM, the problem seemed to dissapear with driver 2.8 or newer.

Alan said...

It might be far fetched, but check this out:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=448360

I had the same problem with my intel card and kuickshow, and rebuilding imlib with this patch solved the problem.